Sometimes, when launching the Thrive Architect/Thrive Theme Builder editor, you might stumble upon the "infinite floating green dots", as seen here:

Basically, the page will never successfully load.

This problem may be the cause of a few different reasons, so we've decided to create this "checklist" that will hopefully help you find and solve the issue.

So, in case you're experiencing the "bouncy green balls" loading screen, make sure you go through each of these steps and see if the issue can be solved as instructed:

1. Clear cache

The very first issue because of which the editor will not load would have to be caching.

The solution here is to make sure you clear your browser cache, as well as purge cache from your caching plugin installed on your WordPress site.

Check out this article if you want to know how and why to clear cache.

2. JavaScript errors

JavaScript errors might also be the case of the endless loading screen in the editor.

→ How do you know if this is the cause?

Open the DevTools tab, by right-clicking on the page/post, and choosing "Inspect" from the drop-down list with the options:

Then, from the top panel, access the console:

This is where you will see any JavaScript errors if that's the case:

→ What do you do if you find JavaScript errors?

The easiest way to get this fixed is to open a support conversation with our team and, ideally, add a screenshot of the JavaScript error.

The error might be caused by various reasons, so it's best that we take a look at it.

3. Plugin/Theme Conflict

If you do encounter a JavaScript error, it is most probably caused by a certain theme or plugin installed on your site. What you can do in this case is identify the source of the error, try to remove the plugin/theme and see if the error still persists.

Here's a relevant example of such an error (click on the image to enlarge it):

In this case, it is very clear that the error/conflict comes from the "Custom Fonts" plugin.

We usually recommend to temporarily deactivate the plugin to see if the issue is fixed. If it is, it means it is a conflict with this plugin and it is best to reach out to either us, to further investigate if anything can be done, or to the plugin developers, as we build our products accordingly to the WordPress Codex.

4. Malfunctioning permalink/server

Another common reason might be the page/post having a broken permalink. Either that, or the request cannot be completed because of a server malfunction.

→ What do you do if the site won't load because of the permalink or server?

  • create a clone of the page/post

An easy way to do that is by accessing the page/post on which the problem occurred and create a clone of it, using the "Clone" option:

  • make sure the HTTP syntax is the same as the WordPress settings

The "http"/"https" syntax of the website should be the same as the ones from the WordPress general settings:

5. iFrame scripts

If you are running scripts on your site, (such as Google Analytics, etc.), they might also interfere with the well functioning of your site and be a cause of the endless loading green dots screen shown in the editor.

You can check whether your website contains scripts or not and, if it does, try to remove them, one by one, to see if either of the scripts are the source of the problem.

The scripts of your site can be managed from the Analytics & Scripts section of the Thrive Dashboard.

6. Cloudflare conflict

A common issue that can cause the editor to load into a continuous, infinite loop, is that your website is using Cloudflare, and it might sometimes cause a conflict with Thrive products.

→ How do you know if your site is using Cloudflare?

Again, you will have to preview your site and access the DevTools tab (right-click -> "Inspect"):

In the "Network" tab, you can pull one of the requests and check whether Cloudflare is listed next to the server or not. For example, this website is using Cloudflare:

There are also some extensions that will show you if Cloudflare is being utilised, such as Wappalyzer, for example:

→ What do you do if your site uses Cloudflare?

In the case of using Cloudflare, you should contact them and ask to check if there are any conflicts between them and our plugins or themes.

Before contacting the Cloudflare team, you can try these two methods:

  • go into Cloudflare and create a new page rule;

  • enter your domain like this: https://your-site.com/*tve=true*

  • the key is tve=true

  • choose "Disable performance" and "Disable apps"

  • lastly, clear your cache.

If nothing changes, you can also try activating the Development Mode of Cloudflare:

  • log in to your Cloudflare account

  • select your domain

  • select the Caching option

  • toggle Development Mode to "On"

7. Check the server limitations

Nevertheless, you should always check with your hosting provider and ask if there are any limitations to the server, that might cause the infinite loading screen. You can also check the server limitations yourself, and you can learn how to do that from this article.

The server might be running out of resources because of set limitations. For example, the request to load the page in Thrive Architect takes too long, and the server reaches a timeout, for which you would have to increase the maximum execution time limit.

If that is the case, the solution is to ask your hosting provider to increase the server limitations. Check out this article for more information on how to do that.

You might also get the "Internat Server Error 500" error in your console, and if that happens please check out this article for more instructions on how to solve it.

If you've tried all of the above-mentioned solutions, and the editor still isn't loading, please make sure to contact the support team, by opening a conversation here.

Did this answer your question?